
Robot 
Sensors 
and 
Sound



 Gather information from the surroundings and send it 
to the computer (called the “intelligent brick” in a LEGO robot)

 Robot sensors can only be used if the robot’s program 
asks for information from them!

 Similarly, the robot can only act on information from 
the sensors if its program tells it to do so!

 The sensors send information through the wires 
(similar to the nervous system in your body) that 
connect them to the computer brick, which uses the 
information appropriately.

2

What do robot sensors do?

How do sensors send signals to the computer brick?



Touch Sensor

 Button-like protrusion

 When bumped, it sends an electrical 
signal to the computer brick via the 
wires saying that it has been touched 

What human sense is this similar to?

Light Sensor

 Detects the amount of light in front of 
the sensor and sends an electrical 
signal via wires to the computer brick 3

How do robot sensors work?



Sound Sensor

 Our ears detect changes in pressure as sound 

 A sound sensor senses the changes in air 
pressure, and sends an electrical signal to the 
computer brick via the wires saying that it has 
heard a sound

 This is similar to how a microphone senses the 
changes in pressure of sound (when you sing) 
and sends it to a speaker!
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How do robot sensors work? (continued)

What is the equivalent human sensor and how does it work?



A microphone is a sound sensor similar to the LEGO sensor we 
just discussed. It converts sound energy to electrical energy.

The microphone below has a diaphragm that moves with sound.

This motion is converted to electricity using a magnet and coil (as 
you will learn later in physics and engineering).
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What is a microphone?



Ultrasonic Sensor

 The sensor looks like a pair of eyes (they are not eyes!)

 Imagine an object is in front of this sensor. The sensor emits 
a sound from one side and receives the reflection on the 
other side. The time it takes for the signal to reach the 
other side helps it estimate the distance to the object. 

 This is similar to how a bat estimates the distance away of 
objects in its path. The estimate of the distance is sent via 
the electrical wires to the computer brick.

 You will learn more about this sensor in later lessons.
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How do robot sensors work? (continued)



Human Sensor Equivalent LEGO Sensor

eyes light sensor, ultrasonic sensor 

ears sound sensor

skin touch sensor

smell
“electronic nose” under development; 

some use in industry

taste
“electronic tongue” under 

development
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What are machine equivalents of human sensors?
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What Is Sound? Activity



1. What is sound?

2. Can sound travel through water?

3. Can sound exist on the moon or in space?

4. What is a microphone?
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Sound Pre-Quiz



1. What is sound?
Sound is created by the vibration of air particles.

2. Can sound travel through water?
Yes. Sounds needs a medium to travel, and water can act as a 
medium. 

3. Can there be sound on the moon or in the space?
Sound waves need a medium (such as air) to travel 
(remember the vibration of particles). There is much less air 
on the moon, and so we can have sound on moon. But outer 
space has no air, and so astronauts are not be able to hear 
sounds in outer space.

4. What is a microphone?
A microphone is a sound sensor. That is, it converts / 
transduces sound into electrical impulses that it sends via 
wires to what it is attached to.
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Sound Pre-Quiz Answers



Oscillation of air pressure is felt by humans as sound.

When air is pushed repeatedly, as by a speaker 
diaphragm, it creates what we call a sound wave.

Watch this video to learn more: 

NASA “Science of Sound” (5 minutes)

http://www.youtube.com/watch?v=_ovMh2A3P5k
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What is sound?

http://www.youtube.com/watch?v=_ovMh2A3P5k


Sound is a mechanical wave: 
Changes in air pressure (vibrations) produce the movement 
of air particles. These particles start bumping into the other 
air particles, and this causes a wave that travels in all 
directions. 

Your ears can detect the wave (as shown in the video). 

The mechanical energy in the wave is sensed by our ears 
and converted to electrical energy, which is transmitted to 
the auditory cortex, and our brain recognizes this as sound. 
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What is sound?



 Vibrating air is sensed as sound. 

 This vibration is like a wave, 
as shown to the right.

 The “loudness” or intensity of sound is measured in decibels (dB), and is 
related is related to its amplitude. The higher the amplitude (higher its 
dB), the louder it sounds.

 The pitch of the sound is its frequency, that is, how many waves happen 
in one second (see the next slide). 

 The higher the pitch, the more shrill it sounds. 13

How do sounds differ?



 Wavelength is the distance 
between any two successive 
“peaks” on the wave. 

 Period is the time required for one 
complete cycle of the vibration. 

 Frequency of the sound is the 
inverse of period, 
that is, frequency = 1/period.

 Amplitude is the height of the 
wave. A loud sound has a high 
amplitude and soft sound has a 
lower amplitude.
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More about sound



15



To the experiment!

Although you cannot “see” sound, you can record it and study its 
properties.

In this experiment we are going to use the microphone port in a 
computer (to capture your voices and other sounds) and 
software that transforms the electrical signal from the 
microphone into a waveform.
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Sound waveforms 
are like the rings of 

waves formed when 
you throw a stone into 
a still body of water 



Watch these additional optional videos:

Acoustic water dance; water on speaker (4:44 minutes)

http://www.youtube.com/watch?v=tI6S5CS-6JI

Seeing sound waves at different pitches (2:10 minutes)

http://www.youtube.com/watch?v=s9GBf8y0lY0
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Seeing Sound

http://www.youtube.com/watch?v=tI6S5CS-6JI
http://www.youtube.com/watch?v=s9GBf8y0lY0


Activity Setup

A microphone is a sound sensor that converts 
sound to an electrical signal, which can then 
be displayed on a computer screen.
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 Your voice is a complex sound wave that contains lots of 
different pitches (frequencies). Boys and girls have different 
pitches in their sounds. 

 Irregular repeating sound waves create “noise,” while regular 
repeating waves seem “musical” to our ears and brain.

 In this activity, you will learn more about the properties of 
sound waves.
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Activity Setup (continued)



1. What were your observations when you generated sounds with 50, 
100, 200, 500, 800,1000, 10000 Hz frequencies and played them?

2. How do “tone” and “noise” differ in their waveforms and how they 
sound?

3. Tap in/on the desk below the computer and see what sound is 
captured by the microphone. What do you observe? 

4. Try singing the solfege notes (do-re-mi-sol-la-ti) one at a time, for 5 
seconds each. What do you observe?

5. Try speaking the same word (like “hello”) in three different tones 
(whisper, normal and loud). What are the main differences between 
the waveforms? 
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Sound Worksheet



 We are using a free, open-source software called Audacity to record and 
edit sound files.

 Start Audacity on your computer > go to File > select New to open a file to 
record sounds.

 Begin by using Audacity to generate waves and see what they sound like 
when played. 

 Go to Generate > from its options, select Tone. For this tone, select a 
frequency and amplitude. Pick frequencies of 50, 100, 200, 500, 800,1000, 
10000 Hz, and leave the amplitude as 0.8. Zoom in and note your 
observations. To delete any record, go to Edit > Remove Audio > Delete.
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Activity Instructions (Using Audacity®)



Under the View 
menu, click Zoom In
until you get a clear 
view of the 
waveform. 

You may need to do 
this several times 
until you see waves 
like those shown 
here.
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Activity Instructions (Using Audacity)



Now try different waveforms than sine, and also try 
increasing the amplitude. What do you observe?

 If you want to delete what you have recorded, go to 
Edit > Remove Audio > Delete.

Go to Generate and from its options > select Noise
and check what that sounds like. Then try the others, 
such as Chirp.

Again, record your observations on the worksheet. 23

Activity Instructions (Sounds Generated by Software)



Next, record your own voice and see what the waveform looks 
like.

Either delete the wave in your present file, or open a new 
project file: go to File > New

To record your own voice using the microphone, click on the 
circular red button (record button) on the playback toolbar, say 
“hello” and see what is being recorded. 

After you record it, play it back using the play button on the 
control panel shown below.
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Activity Instructions (Sounds Generated by You)

Record your voice using the red “Record” button



 TIP: To get a better look at the 
frequencies and amplitudes, click on 
View > Zoom In. You may need to 
keep on clicking several times (6-10x 
closer) to get a clear view of the 
waveform that goes up and down. It 
should look like the one in the figure.

 Use the slider at the bottom to 
browse through the entire wave.
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Activity Instructions (Sounds Generated by You)

 Press Record and say some words (like “hello”) to see the resulting waveforms.

 Then play back what you recorded to see if it sounds like what you recorded.

 The recorded wave form should look like this 

All sounds are waveforms with frequencies and amplitudes! 
Complex sounds have many frequencies of different amplitudes. 

This is true of your own sounds.

 As you can see, the recorded sound has variable amplitudes and multiple 
frequencies, compared to previously “generated” waves with fixed amplitude 
and frequency. 
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Sound Post-Quiz

1. What is sound?

2. What is the difference between a loud 
sound and a soft sound in terms of pitch?

3. Draw sound waves for high-pitch and 
low-pitch sounds.

4. When you hum the same note 
continuously, does it produce a 
distinguishable waveform? 
How about when you scream?



1. What is sound?

Sound is created by the vibration of air particles.

2. What is the difference between a loud sound and a soft sound in 
terms of pitch?

They differ primarily in amplitude and not pitch (frequency). 

3. Draw sound waves for high-pitch and low-pitch sounds.

A high-pitch sound has more waves per unit time, compared to a 
low-pitch sound. (See slide 15 for an example drawing.)

4. When you hum the same note continuously, does it produce a 
distinguishable waveform? 
How about when you scream?

A note usually is close to a “sine” in form, 
while a scream has lots of frequencies. 27

Sound Post-Quiz Answers
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Vocabulary

• olfactory: Related to smell.
• sensor: A device that converts one type of signal to another; 

for instance, the speedometer in a car collects physical data 
and calculates and displays the speed the car is moving.

• ultrasonic: A sound of a frequency that humans cannot hear, 
but dogs and bats can.

• peripheral: Surrounding.



Slide 1: three girls yelling; source: Microsoft® clipart: http://office.microsoft.com/en-
us/images/results.aspx?qu=yelling&ex=1#ai:MP900439297|

Slides 2, 3, 4, 7: LEGO parts; source: LEGO MINDSTORMS NXT User’s Guide

Slide 5: microphone; source: Microsoft® clipart: http://office.microsoft.com/en-
us/images/results.aspx?qu=microphone&ex=1#ai:MC900433836|

Slide 5: Cross section of dynamic microphone; source: Total Venue: 
http://www.totalvenue.com.au/articles/microphones/microphones.html

Slides 13, 14, 15: wave lines and graphs by the author

Slide 16: water nodal lines; source: Microsoft® clipart: http://office.microsoft.com/en-
us/images/results.aspx?qu=water&ex=1#ai:MP900402205|

Slide 17: sand shapes from sound waves; source: pulled from YouTube Seeing Sound Waves video: 
http://www.youtube.com/watch?v=s9GBf8y0lY0

Slide 18: girl, microphone, sound waves by author using clipart

Slides 21, 22, 24, 25: screen capture images by author
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Image Sources

http://office.microsoft.com/en-us/images/results.aspx?qu=yelling&ex=1#ai:MP900439297|
http://office.microsoft.com/en-us/images/results.aspx?qu=microphone&ex=1#ai:MC900433836|
http://www.totalvenue.com.au/articles/microphones/microphones.html
http://office.microsoft.com/en-us/images/results.aspx?qu=water&ex=1#ai:MP900402205|
http://www.youtube.com/watch?v=s9GBf8y0lY0

