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Student Self-Guided Worksheet to Working with Data in Excel

Finding Data and Importing Data into Excel

1.

At Data.gov, search “shoes.” Note that the available datasets are very limited, but note the format of the

available datasets. The comma-separated value (CSV) format, a file format for organized data, most easily
incorporates into Excel. Download the Columbus Avenue BID Businesses CSV file by clicking on the CSV
icon below its description and opening the file with Excel. (Tip: You may have to drag the file to an Excel
worksheet or change the format in the Excel open menu from All Excel Files to Text Files. You can also import the

data using the menu Data > From Text.)
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Data is organized by columns. Columns can be resized to fit the data.
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Shop Mam Telephoni Store Type Store Type Store Type website  Location 1
Lincoln Ce 212.875.5¢ Museums & Cultural Institutior new.lincolncenter.org/
Aerosoles 212 579-8¢ Clothing Shops, Shoes & Acces: www.aerc 310
ATempo 212 769-0: Clothing Shops, Shoes & Accessories 290

Artiste Jey 212 877-3: Clothing Shops, Shoes & Accessories 223

AG Adrian 212 496-5¢ Clothing Shops, Shoes & Acces: www.agje 305

Brief Enco 212 496-5¢ Clothing Shops, Shoes & Accessories 239
Berkley Gi 212 877-4% Clothing S Childrens Stores www.berl 410
Alskling 212 787-7( Clothing Shops, Shoes & Accessories 228

Bit&#39;z 212 724-1¢ Clothing S Childrens Stores www.bitz 410
Comptoir: 212 874-0¢ Clothing Shops, Shoes & Acces:www.mot 184
Club Mon; 212 724-4( Clothing Shops, Shoes & Acces:www.cluk 211
Betsey Jol 212 362-3: Clothing Shops, Shoes & Acces: www.bet: 248
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Harry &#3¢ 212 580-9¢ Restaurants, Cafes & Drinking Ewww.harr 241
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2. Obtain and import data using the following search engines and databases (use a new tab for each search):
data.gov , konect, reddit, refdesk, Internet public library, iTools, Dmoz.org, Encyclopedia.com,
Reference.com, Lifewire, and datahub.io (Tip: It is unlikely that a search will immediately give you
formatted, packaged and relevant data. Try varying your search terms and exploring available data that is
related to the search. For example, searching the term “shoe” does not immediately yield data related to
shoe consumption or preferences. However, a search for “disposable income” may yield Census data with
population demographics that may lead to pertinent and useful trends and results.)

3. Use the Knoema Data Finder plug-in to find data. Here, a direct search of “shoes” yields a table of planned
monthly spending on shoes.

How to add Knoema to Excel:

1) Download the app > go to the File tab > click Options > click Add-Ins.

2) In the Manage box > click COM Add-ins > click Go.

3) Inthe Add-ins available box > select the check box next to Knoema (or Add it first, if it’s downloaded
but not listed)

How to use Knoema Data Finder:

1) Click the Add-Ins tab

2) Click the Find data icon

3) Type your query in the box in place of Search for data and statistics.
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How to obtain data via Excel’s Data > From Web command.

1) Use an Internet browser to find a website that hosts numeric data in tabular form. One example, shown
below, is ESPN’s MLB Player Batting Stats — 2017 page.

2) Copy the website’s URL from the browser address bar.

3) In Excel > go to the Data tab > select From Web (left of the menu, shown below)

4) Paste the URL into the Address in the New Web Query form > click Go.
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5) Click OK to import the data into the existing Excel worksheet. Notice that the data includes lots of
extraneous information, as shown in the next image:
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13 AL MLB AMERICAN LEAGUE MNATIONAL LEAGUE
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15 | Player Pitching Team Pitching Player Pitching Team Pitching Player Pitching Taam Pitching
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20 AL BATTING AVERAGE AvG

21 Jose Altuve 1. Jose Altuve, HOU o.238

22 |Jose 2. Mookie Betts, BOS 0.318

23 Altuve 2. Dustin Pedroia, BOS o.318

2a a. Miguel Cabrera, DET 0.316

25 5. Mike Trout, Lana o.315

26 cemplete Leaders

27

28 Mational League Leaders

29

30 NLBATTING AVERAGE VG

31 DJ LeMahieu 1. DJ LemMahieu, COL o.3a8

32 DJ 2. Daniel Murphy, WsH o.3a7

33 LeMahieu 3. Joey Votte, CIN 0.326

34 4. Charlie Blackmon, COL o.324

6) You can “Clean” the data by hiding (or deleting, with caution) rows or columns that repeat or are
irrelevant. Go to the Data tab > click the Remove Duplicates button > click Select All > click OK.
Manually hide remaining irrelevant text and information by selecting the rows or columns:
right-click > select Hide. Save your progress for the next section.
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25 21 1.T. Realm MIA 0.307 3.3 0112 0.as9 1m 99 112 0.038 0.23
26 22 Robinsan SEA 0.306 60.5 695 0241 0315 120 153 0.78 1721 0071 0.a5
27 23 Eric Hosm KC 0.305 52 647 0185 0292 138 96 1.44 248 0088 0.44
28 24 Charlie BI;COL 0.305 as.2 703 0205 0313 79 121 056 216 o0.088 058
25 25 Francisco CLE 0.304 50.1 586 0157 0.284 140 123 114 295 0.083 0.65
30 26 Dustin PelBOS 0.304 a7.9 558 0139 0259 130 137 0.95 431 0.098 0.75
a1 27 Qdubel HePHI 0.303 521 67  0.a24 0.29 11 122 091 363 0123 0.71
27 28 Janathan [ MIL 0.303 46.6 658 0198 0307 a3 130 0.64 261 0.088 0.a3
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coov 7 32 Brandon B SF 0.3 s6.8 7.6 0223 0377 51 155 0.41 273 0142 0.81
Paste options: 3 33 Miguel ca DET 0.299 56.7 672 0237 0352 118 132 0.89 169 0102 0.61
2 5 34 Janathan ' MIL 0.299 a9.5 614 013 0324 122 82 1as 473 o 0.a3
] 35 Corey Sea LAD 0.299 56.7 6.65  0.2a1 0328 121 132 0.92 183 0.085 0.a8
Paste special i 36 Gregory P PIT 0.299 513 6.76 0.216 0.369 a7 123 0.71 26.8 0.119 0.58
Insert B 37 Paul Gold: ARI 0.298 63.7 7.99 0.214 0.46 94 115 0.82 20.4 0.177 0.8
Delete 5 38 Janathan ! BAL 0.298 aa.4 553 0215 0.26 103 124 0.83 222 0.0a2 0.2
Clear Contents  § 39 Carlos Bel NYY 0.297 a7.1 545 0274 0335 89 123 0.72 13.8 0.056 0.3

4. Explore your own searches using the given tools.

Big Data, What Are You Saying? Activity—Student Self-Guided Worksheet to Working with Data in Excel



Name: Date: Class:

Formulate Product Plan and Gather Data

This includes: Identify a product. Determine at least five variables related to the product’s production,
marketing and sales. Search for data using a variety of search resources and search terms. Import relevant data
into Excel. Keep records of the data source URLS.

Analyzing Data with Excel

Practice inserting a scatter plot of related columns of data in order to analyze their relationship by inserting a
trend line and viewing the coefficient of determination (R?). These tools enable a visual analysis and provide a
statistic of the correlation between the data, which show the strength of their interrelation.

1. Open the Excel file from the earlier importing data exercise (or ask the teacher for access to the ESPN
Example file). Select the first column (or row) of data by clicking and highlighting just the data values, or
by selecting the row or column header at the top. Then hold down the control key (Ctrl, usually near the
space bar on the keyboard) while selecting the second row or column of data. As an example, select
columns D (AVG) and | (GB) > go to the Insert menu > select Scatter > select the Scatter with only
Markers option > move the chart to a blank, open area in the Excel sheet.
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[ 10| 8 Carlos Gor COL 0.329 61.6 8.15 0.255 0.332 108 118 0.92 16.6 0.069 0.31
[12 ] 3 DJ LeMahi COL 0.326 46.2 6.21 0.171 0.291 128 103 1.2a 51.6 0.097 0.81
12 10 Ryan Brau MIL 0.325 as.a 7.22 0.229 0.325 115 91 1.26 19.2 0.077 0.a8
[ 2a] 11 Mike Trou LAA 0.323 70.4 9.32 0.251 0.457 100 131 0.76 17.1 0.145 0.81
[ 15 | 12 Victor Mai DET 0.322 as.8 6.73 0.201 0.271 87 146 0.6 19.5 0.064 0.a5
|16 | 13 Eduardo K MIN 0.319 as5.8 6.19 0.168 0.253 122 117 1.0a 2a.8 0.034 0.26
17| 14 lan Desmc TEX 0.318 60 7.33 0.203 0.318 115 118 0.97 222 0.073 0.31
[ 18| 15 Aledmys [STL 0.316 as8.9 7.09 0.207 0.293 104 120 0.87 25.6 0.077 0.59
[ 19 | 16 Martin Pre MIA 0.315 40.9 5.11 0.088 0.159 141 120 118 147.5 0.069 0.59
| 20| 17 Marcell O: MIA 0.314 56 7.44 0.24 0.321 59 126 0.75 17.5 0.076 0.38
[ 21| 18 Jean Segu ARI 0.311 50.6 5.94 0.123 0.211 155 120 1.29 63.6 0.058 0.a3
[ 22| 19 Christian Y MIA 0.311 a7.5 6.5 0.159 0.303 124 82 1.51 aa 0.121 0.62
[ 23] 20 Yunel Escc LAA 0.31 36.8 a.73 0.099 0.164 143 101 1.41 91.3 0.066 0.56
[ 25| 21 J.T. Realm MIA 0.307 33.3 4.86 0.112 0.159 111 99 112 62.8 0.038 0.23
| 26 | 22 Robinson SEA 0.306 60.5 6.98 0.241 0.315 120 154 0.78 17.1 0.071 0.49
| 27 23 Eric Hosm KC 0.305 52 6.47 0.185 0.292 138 96 1.4a 2a.8 0.083 0.44
| 28 | 24 Charlie Bl: COL 0.305 a9.2 7.03 0.205 0.313 79 141 0.56 21.6 0.086 0.58
| 29 | 25 Francisco CLE 0.304 50.1 5.96 0.157 0.284 140 123 114 29.9 0.083 0.65
| 30| 26 Dustin PeBOS 0.304 47.9 5.58 0.139 0.259 130 137 0.95 4.1 0.096 0.75
[ 31| 27 Odubel H(PHI 0.303 52.1 6.7 0.124 0.29 111 122 0.91 36.3 0.125 0.71
| 32| 28 Jonathan | MIL 0.303 46.6 6.58 0.199 0.307 83 130 0.64 26.1 0.086 0.49

2. The chart auto-scales the axes. To customize the graph, double click on the values along one of the axes to
bring up a menu with options.
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3. To customize the output, double click on part of the graph to bring up a menu box with options. Right click
on the data points themselves to add a trend line, as shown below. In the Format Trendline box that
appears, check the boxes Display Equation on chart and Display R-squared value on chart. (The R-squared
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value, or the coefficient of determination, is a value between 0 and 1, in which, essentially, 0 indicates no
relation, and 1 indicates a perfect relation.)
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BIE=E=A-H-2- ¥4
250 § . ai—— + + *
Delete Series + & "
- + h *
&4 Reset to Match Style : + eco
I'Lh Change Series Chart Type...
[ Select Data..
Add Data Label T T T T T 1
Add Trendiine... D31 032 033 034 035 036

:f];‘ Format Data Point...

Note in this example, the R? value is 0.0089, which tells us that in this dataset, very little correlation exists
between batting average and number of ground balls. Keep in mind that finding no correlation is useful
knowledge! Experiment with other columns to note differences in plots, trends and R? values.

Load the Analysis ToolPak (included with Excel) by clicking on the Developer tab >selecting it from Add-
Ins Available. After loading > go to the Data tab > click Data Analysis, then:
e Explore Histogram, Descriptive Statistics, Correlation and others.
See the online Microsoft Help for more details on the use of the Analysis ToolPak.
e Experiment with variable pairs and graph customization, taking note of shape and trend line differences

Use the remaining time to continue to search for and import data.
Remember to continually save your progress!

Research and Analyze Data

Focus on the goal of the project: To find relevant variables’ effect on the data and make decisions as to
planning and marketing.

Create scatter plots, trend lines, and R2 values for collected data collected. Also, find descriptive statistics
via the Analysis Toolpak.

What do you learn from the data? For example, the low correlation between ground balls and batting
average may suggest that batting average is more attributed to fly balls and line drives. Or, perhaps the best
hitters hit ground balls as often for outs as they do for hits. These conjectures can lead to more research
and discovery; however, each conjecture by itself is weak and might not be good advice without testing the
data. Be careful not confuse correlation with causation.

Note that the results may not reinforce your opinions and expectations. Look for creative responses and
solutions; conduct further research as necessary.

Create a Presentation of Analysis
Create an electronic presentation of your research. Suggested outline:

Page 1: Introduction with topic; include images, overview, why did you chose this topic?

Page 2: Related variables with explanations; why was it chosen? how did it come up?

Page 3: Graphs and relations with variables; explain patterns and/or lack of patterns, trends, inferences

Page 4: Difficulties; where would you recommend more emphasis? What was lacking? What do you wish you would
have located or discovered? What goals were not supported?

Page 5: Recommendations based on research; give degree of risk of proposal, explain why you would recommend
and what benefits may occur

Finish Work and Give Presentation

Complete presentations that summarize your research, graphs, interpretations and conclusions, and present to
the class for assessment by the outline and rubric criteria.
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